Service manager Exchange connector

 

After reading all the documentation of the exchange connector I  received the message “connector finished with error. “

After diving into the logs I found the following exchange connector Event Logs.

 

Issue 1

AutodiscoverConfiguration: <Trace Tag=”AutodiscoverConfiguration” Tid=”17″ Time=”2011-02-03 09:18:16Z”> failed: WebException (The underlying connection was closed: An unexpected error occurred on a send.) </Trace>

Solution 1

http://social.technet.microsoft.com/Forums/en-US/systemcenterservicemanager/thread/9d28361c-5a90-462a-81fa-2931d656e604/#e602946b-4f05-41f3-9347-cc7460be36d9

The solution was to make sure I could access as as the workflow user the the following url’s without a certificate error or other errors

https://<urltomailserver>/autodiscover/autodiscover.xml

https://<urltomailserver>/ews/exchange.asmx

Which in my environment redirects to

https://<urltomailserver>/ews/services.wsdl

 

Issue 2

EwsResponseHttpHeaders: <Trace Tag=”EwsResponseHttpHeaders” Tid=”18″ Time=”2011-02-02 03:02:39Z”> 401 Unauthorized
Server: Microsoft-IIS/7.5
WWW-Authenticate: Negotiate,NTLM
X-Powered-By: ASP.NET
Date: Wed, 02 Feb 2011 03:02:39 GMT
Content-Length: 0 </Trace>

A Windows Workflow Foundation workflow failed during execution.

Workflow Type: Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow Workflow Identifier: 2f93ba28-875b-b0ab-cf37-26a3d42fa633
Exception Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException Exception Message: The request failed. The remote server returned an error: (401) Unauthorized.
Exception Stack: at Microsoft.SystemCenter.ExchangeConnector.ExchangeInbox.
ProcessMail() at Microsoft.SystemCenter.
ExchangeConnector.ProcessEmailsWorkflow.Execute(ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.CompositeActivityExecutor`1.
Execute(T activity, ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext) at  System.Workflow.ComponentModel.ActivityExecutorOperation.
Run(IWorkflowCoreRuntimeworkflowCoreRuntime) at System.Workflow.Runtime.Scheduler.Run()

 

Solution 2

On the Exchange IIS server there was an issue with  the authentication methods. 

 image

 

To fix this issue I had to disable forms authentication from the main site.

This made disappear this error messages in the service manager log.

Advertisements

About arnepeleman

I am a system center enthusiast, IT Geek. View all posts by arnepeleman

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: